There are some hints that make life with NetBSD easier:
# ifconfig -a #shows the network devices
# dhclient fxp0 #asks the dhcpd for an address
to make this permanent add the following to your /etc/rc.conf:
dhclient=YES
# export PKG_PATH="http://ftp.NetBSD.org/pub/pkgsrc/packages/NetBSD///All"
NetBSD/386/5.0.1_2009Q3/All
)# pkg_add -v cups
# cd /usr/
# ftp ftp://ftp.netbsd.org/pub/pkgsrc/pkgsrc-2009Q3/pkgsrc.tar.gz
# tar -xzvf pkgsrc.tar.gz
# cd /usr/pkgsrc/print/cups
# make install
Normally, this is ok, and the program is installed. However some apps or services, such as cups, need further treatment# cp /usr/pkg/share/examples/rc.d/cupsd /etc/rc.d/
# /etc/rc.conf/cupsd start
cupsd=YES
slpd=NO
And there is one more thing. BSD system gives priority to native lpd printing. To make cups work well we need to: # mv /usr/bin/lp /usr/bin/lp.old
# mv /usr/bin/lpr /usr/bin/lpr.old
# mv /usr/bin/lpd /usr/bin/lpd.old
# mv /usr/bin/lprm /usr/bin/lprm.old
# ln -s /usr/pkg/bin/lp /usr/bin/lp
# ln -s /usr/pkg/bin/lpr /usr/bin/lpr
# ln -s /usr/pkg/bin/lpd /usr/bin/lpd
# ln -s /usr/pkg/bin/lprm /usr/bin/lprm
- HOME
~~~~~~~~~~~~~~~
- OpenBSD
- NetBSD
- FreeBSD
- Linux
- Solaris
- Windows
~~~~~~~~~~~~~~~
- Git
- Ansible
- Atlassian
- Network tools
- Qemu
- Virtualbox
- Vim
- Tmux
- Mutt
- STar
~~~~~~~~~~~~~~~
- MySQL
- PostgreSQL
- Postfix
- OpenSSL
- tcpdump
- SSH
~~~~~~~~~~~~~~~
- Packet Filter
- IP Filter
~~~~~~~~~~~~~~~
- Bash
- web-dev
- Hacking
- LINUX DAYS